Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 10, 2026 - 07:00 UTC
Scheduled
Please be advised that we will be performing scheduled performance enhancements to our US environment this coming Sunday, May 10. While we do not anticipate any downtime, users may experience intermittent latency on the User Activities and Journey Analytics pages during this period. These improvements are part of our ongoing commitment to providing a faster and more robust experience. We appreciate your patience as we work to enhance our platform.
Posted May 06, 2026 - 10:54 UTC
This scheduled maintenance affected: Detection and Response Services (Detection and Response US), Authentication Services (Authentication US), Identity Management Services (Identity Management US), Identity Verification Services (Identity Verification US), Identity Orchestration Services (Identity Orchestration US), and Mosaic Portal (Mosaic Portal US).