Resolved
All services have returned to normal operation
Posted Nov 18, 2025 - 17:22 UTC
Update
The situation on the provider’s side is still evolving, and we are closely monitoring their recovery efforts.
Posted Nov 18, 2025 - 16:40 UTC
Monitoring
Cloudflare are stating that the issue should be resolved
Posted Nov 18, 2025 - 12:30 UTC
Investigating
Investigating: We are currently investigating issues related to Cloudflare that may be impacting service
Posted Nov 18, 2025 - 12:01 UTC
This incident affected: Detection and Response Services (Detection and Response Europe, Detection and Response US, Detection and Response Canada, Detection and Response Australia, Detection and Response Sandbox), Authentication Services (Authentication Europe, Authentication US, Authentication Canada, Authentication Australia, Authentication Sandbox), Identity Management Services (Identity Management Europe, Identity Management US, Identity Management Canada, Identity Management Australia, Identity Management Sandbox), Identity Verification Services (Identity Verification Europe, Identity Verification US, Identity Verification Canada, Identity Verification Australia, Identity Verification Sandbox), Identity Orchestration Services (Identity Orchestration Europe, Identity Orchestration US, Identity Orchestration Canada, Identity Orchestration Australia, Identity Orchestration Sandbox), BindID Services (BindID Europe, BindID US, BindID Sandbox), and Mosaic Portal (Mosaic Portal Europe, Mosaic Portal US, Mosaic Portal Canada, Mosaic Portal Australia).