AWS is currently experiencing issues. We are actively monitoring the service status, and so far, we have not identified any impact on our systems

Incident Report for Transmit Security Status Page

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 10:45 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:01 UTC

Monitoring

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 10:01 UTC

Investigating

AWS is currently experiencing issues. We are actively monitoring the service status, and so far, we have not identified any impact on our systems
Posted Oct 20, 2025 - 09:51 UTC