BindID US activity log is unavailable

Incident Report for Transmit Security Status Page

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 18:47 UTC

Investigating

We are currently investigating this issue
Posted Jul 29, 2025 - 16:36 UTC
This incident affected: BindID Services (BindID US).