DRS services - performance degradation

Incident Report for Transmit Security Status Page

Resolved

This incident has been resolved.
Posted Nov 05, 2025 - 03:03 UTC

Identified

The issue has been identified and currently resolution is in progress.
Posted Nov 04, 2025 - 23:27 UTC

Investigating

DRS services experience slight admin performance degradation affecting certain features in the platform:
* Recommendation Updates: Actions such as assignee changes and list updates may take longer than usual to execute. Please note that all functionality remains operational, only execution times are affected.
* Investigate Panel and Page: You may experience slower updates or delays before the Investigate panel and page becomes available after certain actions.
Posted Nov 04, 2025 - 21:27 UTC
This incident affected: Detection and Response Services (Detection and Response US).