Scheduled maintenance is currently causing minor performance issues for our US-based customers

Incident Report for Transmit Security Status Page

Resolved

This issue is resolved
Posted Mar 29, 2026 - 10:15 UTC

Monitoring

A configuration update has been applied, and all services have returned to normal operation
Posted Mar 29, 2026 - 10:13 UTC

Identified

We are continuing to investigate the issue
Posted Mar 29, 2026 - 10:08 UTC

Investigating

We are currently resolving the issue
Posted Mar 29, 2026 - 09:29 UTC
This incident affected: Authentication Services (Authentication US) and Identity Management Services (Identity Management US).